Suppose you have a secure website. Your company’s SharePoint site, for example, or CRM deployment, or OWA email. You’ll want to have your users access the site securely using SSL (a.k.a. the https:// part of the web address). But what happens if your users enter http:// instead? Or just type the web address and omit the http portion completely? They’ll get a 404 Not Found error, that’s what. And in many cases among not-so-computer-savvy users this can cause panic as they think that the website is down.

A Google search brings up lots of methods of redirecting the user to the SSL website, but many of them are tricky to implement at best. Luckily, there is a quick and easy method of redirecting the website if you are using IIS 6 or higher in Windows.

1.  First, create a new website in IIS. Call it something simple, like CRM Redirect. Under the Binding section, in the Host Name header, make sure to enter the webaddress that you want users directed from. For example, if our target web address is https://crm.yourcompany.com, you will want it to be crm.yourcompany.com (by the way, you can even use this to redirect a completely different address – for example, thatcrmthing.yourcompany.com, to crm.yourcompany.com, provided you have the webaddress in your DNS).

IIS create new website

2.  Next, click on your newly-created website and go to the HTTP Redirect module.

(click to enlarge)

3.  In the HTTP Redirect module, click the “Redirect requests to this destination” and enter the https:// web address you want all requests to go to. Click the checkbox for “Redirect all requests” and for the Status Code, make sure it lists “Found (302)”. (For more information on what these status codes mean, and when to chose which one for given situations, see the Microsoft TechNet Article.) Click Apply in the right-hand Action pane.

(click to enlarge)

4.  Now go to the actual website that has the https: binding (in the above example, it is called “Microsoft Dynamics CRM”) and open the SSL Settings.

 (click to enlarge)

5.   In the SSL Settings, make sure that “Require SSL” is not checked. Click Apply in the right-hand Action pane, and you’re done!

(click to enlarge)

Like this post? Share it!